Symptom
When consuming federated URL, the IDP throws error message: "Due to an invalid request, we're unable to complete the authentication process"
Environment
SAP SALES CLOUD CPQ
Reproducing the Issue
- Adjust federation settings in accordance with your IDP
- Consume <domain>.cpq.cloud.sap/fsso
- Page with error is returned.
Cause
This is a bug on application confirmed by development team.
Resolution
Version for release is set as 2408. As workaround, these steps should be followed:
- Sign On Request Binding should be defined as Post
- Log Out Request/Response Binding should be set to Post
- After changing the bindings, the metadata should be uploaded again to IDP.
See Also
Keywords
Federation, SSO, Login, Error, Bug, CPQ , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , Known Error
Product
SAP CPQ 2024