SAP Knowledge Base Article - Public

3487362 - CPQ Federated SSO throws generic error

Symptom

When consuming federated URL, the IDP throws error message: "Due to an invalid request, we're unable to complete the authentication process"

Environment

SAP SALES CLOUD CPQ

Reproducing the Issue

  1. Adjust federation settings in accordance with your IDP
  2. Consume <domain>.cpq.cloud.sap/fsso
  3. Page with error is returned.

Cause

This is a bug on application confirmed by development team.

Resolution

Version for release is set as 2408. As workaround, these steps should be followed:

  1. Sign On Request Binding should be defined as Post
  2. Log Out Request/Response Binding should be set to Post
  3. After changing the bindings, the metadata should be uploaded again to IDP.

See Also

Federated Single Sign-On

Keywords

Federation, SSO, Login, Error, Bug, CPQ , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , Known Error

Product

SAP CPQ 2024