Symptom
Error message 'Internal Error' is displayed when opening app 'Manage My Timesheet' and navigating to a specific week in order to record time for a task.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Open app 'Manage My Timesheet';
- Navigate to a week/month in which a task should be available for booking;
- Notice that the 'Internal error' message will be displayed.
Cause
A possible cause for this issue is that a Purchase Order (PO) directly linked to the task has multiple Item Account Assignments.
A Purchase Order Item having multiple Account Assignments, such as multiple WBS Elements, is currently not supported in SAP. This is mentioned in page 33 of Scope Item J13 (under topic 4.2 - Service Procurement), as follows:
"A purchase order item with multiple account assignment objects such as WBS element and cost center is not supported. Please use only one account assignment object."
Resolution
In order to fix this issue, it is necessary to remove any additional Item Account Assignments from the Purchase Order directly related to the task.
Also, it is important to keep in mind that the same message will also be prompted in case of existing PO's having multiple Item Account Assignments, and being indirectly related to the PO from the task. A Purchase Order is indirectly related to another once they both share the same Supplier or Service Performer.
So, it is necessary to also check and remove additional Item Account Assignments from PO's with the same Supplier and/or Service Performer as the PO directly related to task.
See Also
For further information, check Scope Item Service and Material Procurement - Project-Based Services (J13).
Keywords
S/4HANA Cloud, internal error, timesheet, manage my timesheet, task, my tasks, purchase order, po, purchase order item, account assignment, item account assignment, j13 , KBA , CA-TS-S4 , Cross Application Timesheet in S/4HANA , Problem