SAP Knowledge Base Article - Public

3487630 - EC Alerts and Notifications job is failing due to the error "Cannot invoke "java.util.Map.get(Object)" because "numAlertsMap" is null" - Employee Central

Symptom

EC Alerts and Notifications job is failing due to the following error:

"Error occurred. java.lang.NullPointerException: Cannot invoke "java.util.Map.get(Object)" because "numAlertsMap" is null"

Environment

SAP SuccessFactors Employee Central

Reproducing the Issue

  1. Run EC Alerts and Notifications job either once or in a recurring basis;
  2. Check it failed;
  3. Upon checking job results, the following error message can be found:  "Error occurred. java.lang.NullPointerException: Cannot invoke "java.util.Map.get(Object)" because "numAlertsMap" is null".

Cause

Business Rule name fetched in job execution exceeds the maximum length of 100 characters.

Resolution

Identify the Business Rule that is being triggered by the job which exceeds the maximum length and adjust it. 

To check which rules have been picked up by the job, navigate to Scheduled Job Manager > Job Monitor > find the respective job that is failing > click on "View Details".

See Also

2462997 - EC Alerts and Notification Job Failing

Keywords

Error occurred. java.lang.NullPointerException: Cannot invoke "java.util.Map.get(Object)" because "numAlertsMap" is null, SQLException: SAP DBTech JDBC, inserted value too large for column: TrexUpdate failed on table, ALERT_ENTRY, with error: AttributeEngine: indexed value not within specified range; max length (100) violated on pos 0, ec alerts and notifications, fail, failing, job failing, job fail, job, provisioning, scheduled job manager, view details, job monitor, employee central , KBA , LOD-SF-EC-ALR , Alerts & Notifications (saveAlert - EC Core only) , How To

Product

SAP SuccessFactors Employee Central all versions