SAP Knowledge Base Article - Public

3488150 - Incoming Emails not creating cases in the system

Symptom

  • Incoming emails are not automatically creating cases in SAP Service Cloud V2.
  • The Case conversion monitor captures the exception: "An internal server error occurred while running the Connector Service...."
  • This issue persists even after reprocessing the entry.

Environment

  • SAP Service Cloud Version 2 1.0
  • SAP Sales Cloud Version 2 1.0

Reproducing the Issue

  1. Configure the Email Channel as required.
  2. Navigate to SettingsCase Auto Creation Monitoring.
    • Observe the error: "An internal server error occurred while running the Connector Service."
  3. Open the Browser's DevTool and check the network logs. The following errors are typically seen:
    {
      "message": "An internal server error occurred while running the Connector Service",
      "type": "TRANSIENT",
      "stackTrace": "[com.sap.crm.casecommonlib.exception.ExceptionFactory.createGRPCException(ExceptionFactory.java:99), com.sap.crm.casechannelconnectorservice.grpc.connector.ConnectorServiceImpl.sendAndReceive(ConnectorServiceImpl.java:64), com.sap.crm.casechannelconnectorservice.mapper.InteractionEmailToCaseMapper.invokeWebhook(InteractionEmailToCaseMapper.java:554), ....]"
    }

Cause

Missing configuration

Resolution

To resolve this issue, follow these steps:

  1. Review Channel Configuration:

    • In the SAP Service Cloud system, check if the options for Case Type Determination and Party Determination from custom code extensions are enabled under Channel Configuration.
    • If so, ensure the communication configuration to integrate with custom code is properly set up.
      • If you intended to use custom code for determining case types and party roles, verify that the necessary communication configurations are in place.
      • Without these configurations, the system will fail to execute the email-to-case conversion, resulting in the mentioned error.
      • See "Working with Determination in the Service Cloud V2 " for an example.
  2. Disable Custom Code Determination (If Not Used):

    • If custom code determination is not planned to be used currently, you can disable these options in the channel configuration. This will resolve the error.
    • Navigate to SettingsChannelDetermination Rules.
    • Disable the options:
      • Case Type Determination From Custom Code Extensions
      • Party Determination From Custom Code Extensions
    • Save the changes and monitor if the issue persists.

Keywords

email to case conversion, incoming emails, automatic case creation, connector service error, internal server error, case auto creation monitoring, custom code extensions, case type determination, party determination, SAP Service Cloud V2, SAP Sales Cloud V2, channel configuration, email channel, case conversion monitor. , KBA , CEC-CRM-CAS , Case Management for SAP Sales/Service Cloud , Problem

Product

SAP Sales Cloud and SAP Service Cloud Version 2 1.0