Symptom
You have created a specific Routing Rule and Activity Plan for Visits that includes a Survey with frequency "Once".
For Account ABC: the Survey gets attached to the 1st Visit.
For Account DEF the Survey gets attached to a later Visit (like 3rd or 4th).
Environment
SAP Cloud for Customer
Cause
For Visits created via Routing Rule, the standard behavior is to have the Survey assigned to the 1st Visit.
If this Survey is left uncompleted and there's a Visit in which you perform a manual action such update a field (such as end date time), this will retrigger the assignment background job as long as it's within the Activity Plan validity.
This will cause the Survey with frequency 'Once' to get reassigned to the latest changed and open Visit based on the background job.
Resolution
Please check the change log of the Visit that was assigned the Survey with frequency 'Once'.
This manual change retriggered the job and by system design, since this is the latest updated and open Visit, the Survey will get reassigned to it.
If you cancel the visit or complete the visit without completing the one-time survey:
-
Automatically move to next existing or generated visit within the date range defined in the activity plan. OR;
- Stay in the original visit as incomplete surveys forever, for example, when the activity plan is no longer in the validity period.
If you complete the one-time survey during the first visit.
-
You don't see that survey again for the remainder of the date range defined in the activity plan.
See Also
Keywords
Survey, Activity Plan, Routing Rule, Frequency , KBA , LOD-LE-SUR , Survey , LOD-CRM-ACT , Activities , Problem