Symptom
- Unable to use Integration Center to update a single field in JobRequisition, JobApplication or Candidate entity.
- The request preview is not being populated after mapping destination fields, such as Picklist, Object, Attachment, etc.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
Upserting a Picklist field in JobApplication entity.
- Go to Integration Center.
- Create a Scheduled CSV Input Integration.
- Select the JobApplication entity.
- Upload a Sample CSV that contains two columns: Job Application ID and Picklist Option ID.
- Map the Job Application ID column to "applicationId".
- Map the Picklist Option ID column to the "id" of the picklist field.
- Notice that the mapped fields are not appearing in Preview.
Cause
Integration Center cannot generate the request payload if only navigation properties, such as Picklist, Object, Attachment, etc., are mapped without including any other non-navigation field from the starting entity.
Resolution
To resolve this, map an additional non-navigation field (such as Text, Number or Date) from the starting entity.
For the JobRequisition entity:
Map an additional field "isDraft" with a default value of "true".
It is necessary to include the isDraft=true value in order to bypass required fields. For more information, refer to the KBA 2771951.
For the JobApplication entity:
Map an additional field "candidateId" with the Candidate IDs extracted from the Job Applications.
For the Candidate entity:
Map an additional field from the Candidate Profile Template with the data extracted from the Job Applications. The field's upsertable/updatable attribute must be "true" as per the OData API Data Dictionary.
See Also
KBA 2771951 - How to update Job Requisition fields using Integration Center - Recruiting Management
KBA 3417054 - How to Mass Update Job Application Fields using Integration Center - Recruiting Management
Help Portal: Using the Integration Center: Using Configure Fields Tab For Inbound Integrations
Keywords
RCM, INC, Integration Center, Mapping, Association, Picklist, Required, Failed, Update, Upsert, Inbound Integration, Navigation, Property, API, OData, Entity , KBA , LOD-SF-RCM-INT , Integration Center & Intelligent Services , LOD-SF-RCM-JOB , Job Postings & Requisitions , LOD-SF-RCM-APP , Applicants and Job Applications , LOD-SF-RCM-CAN , General Candidate Issues (not Offers, not Profiles) , Problem