Symptom
- When merge users in bulk using import data tool, but the validation status is "Failed".
- Download result and show error messages:
-
- Email addresses don't match
- Person external IDs don't match
Environment
SAP SuccessFactors Learning
Reproducing the Issue
- Go to Learning Administration > System Administration > System Management Tools > Import Data.
- From the Entity Type list, choose Person.
- To import the file, in Action, choose Import Data.
- The Merge option is automatically selected in Import Option.
- In Import File, choose the file you want to upload, and select your time zone.
- Choose Validate.
- The status will show "Failed".
- Download the report of the job, there is error message: Either 1)Email addresses don't match or 2)Person external IDs don't match, or both.
- But when administrator actually 'Merge' the users, it will succeed.
Cause
This is a validation warning to inform the administrator that two user accounts have different email address and user ID, in case the administrator has accidently put two wrong users.
Resolution
- This system behavior is by design and is confirmed by development team and PM team.
- 'Validation' and 'Merge' are two different jobs and they are not associated in any way. The 'Merge' job will ignore the validation warnings and run successfully.
- When you have two different User IDs and you select Validation option it will show errors which are warnings and it will fail to merge.
Note: If you are happy to proceed with merging users with different user IDs intentionally then you can proceed with 'Merge' import option to successfully merge without this warning.
1. Your file will look something like this:
2. You then select the merge option and select 'Submit'.
See Also
2096262 - Merging users in SAP SuccessFactors Learning - SAP for Me
Keywords
Merge Users in Bulk, import data, validation, Failed , KBA , LOD-SF-LMS-IMP , Import Data Tool , Problem