SAP Knowledge Base Article - Public

3492125 - External Key of a record is not visible in data workbench export

Symptom

Create an external key for any record of a business object and the created external key is not displayed in the data workbench export

Environment

SAP Cloud for Customer

Reproducing the Issue

1. Open Data workbench import

2. Choose the required BO and update the external key using the standard template

3. Export that record

4. External key field is empty

Cause

The external key was not updated/assigned even though the monitor shows that it is successful. This is because, data workbench external key needs to be assigned using ID mapping tool and cannot be assigned using standard template of insert/update.

Resolution

  1. Navigate to data workbench ID mapping
  2. Download the template and fill the required data
  3. Perform the import
  4. Now, export the the record and external id will be seen

Keywords

External key, id mapping, not visible, missing, export, import, data workbench , KBA , LOD-CRM-INT-DWB , Data Workbench , Problem

Product

SAP Cloud for Customer core applications 2405