Symptom
Customer is facing the error message below on message monitoring
{
"code": "inbound-data-connector.132",
"message": "Failed to process the inbound message.",
"details": [
{
"code": "400",
"message": "{\"error\":{\"message\":\"Deletion of Business Partner role ABC forbidden.\",\"code\":\"sap.crm.md.service.businessPartnerService.businessPartnerMessage.roleDeleted\"}}"
}
]
}
Environment
SAP Sales Cloud and SAP Service Cloud Version 2.
SAP Sales Cloud and SAP Service Cloud Version 2 integration S4.
Reproducing the Issue
In CNS,
- Go to "Settings".
- Go to "All Settings" tab.
- Under Integration tab, go to "Message Monitoring".
- Search for the message ID: XXXXXXXXXXXX.
- Check the error message "Deletion of Business Partner role ABC forbidden.".
{
"code": "inbound-data-connector.132",
"message": "Failed to process the inbound message.",
"details": [
{
"code": "400",
"message": "{\"error\":{\"message\":\"Deletion of Business Partner role ABC forbidden.\",\"code\":\"sap.crm.md.service.businessPartnerService.businessPartnerMessage.roleDeleted\"}}"
}
]
}
Cause
Check the field "validityPeriod"
"validityPeriod": { of the role
"validFrom": "2024-07-03",
"validTo": "2024-07-03"
This means there is no currently valid role and this is not supported in CNS.
Resolution
Customer needs to change the validity of the role in S/4.
Keywords
Deletion of Business Partner role, validityPeriod. , KBA , CEC-CRM-INT , Integration for SAP Sales/Service Cloud , CEC-CRM-DC , Data Connector for SAP Sales/Service Cloud , Known Error