Symptom
When running the checks for Job Description Manager application in Admin Center > Check Tool, issue(s) for the check "JPBCompetencyAndBehaviorDataDoesNotExistCheck" are found.
NOTE: This is a check specifically for the JDM to TIH Migration and will only be displayed when JDM is enabled.
Environment
SAP SuccessFactors Talent Intelligence Hub
Cause
The check indicates if data is already present in Job Profile Builder (JPB) when trying to migrate from Job Description Manager (JDM) to Talent Intelligence Hub (TIH). If JPB data is already present, the TIH migration will try to load the same competencies but there is a processing error because duplicate competencies are already present.
Another scenario that causes this check :
The checkbox Competency Library Management Suite is enabled in Provisioning(Company Settings) when JPB is already enabled in customer system.
Resolution
The migration from JDM to JPB will need to be completed first before attempting a TIH migration. Steps on how to complete the migration are in 2276692 - Best Practices on Job Description Manager to Job Profile Builder Migration.
Another scenario to resolve issue
Competency Library Management Suite should be disabled (if you do so then it will automatically disable the JPB)
To which you will just need to re-enable the JPB back and you will see that the check error will be resolved.
Keywords
success factors, SF, SFSF, JDM, JPB, TIH, CofC, CoC, migration, Job Profile Builder, Job Description Manager, Center of Capabilities, Talent Intelligence Hub, JPBCompetencyAndBehaviorDataDoesNotExistCheck, CHECKTOOL_JPB_COMPETENCY_AND_BEHAVIOR_DATA_EXIST_DOES_NOT_EXIST_CHECK, WSM-26539, Competency Library Management Suite , KBA , LOD-SF-TIH-MIG , Migration to Talent Intelligence Hub , Problem