SAP Knowledge Base Article - Public

3492449 - Unable to Approve Sales Quote from ByD Mobile APP

Symptom

When you try to approve a Sales Quote from ByD Mobile APP, system throws below error but you are able to approve the same Sales Quote from UI without any issues

Enter an e-mail address in output settings

Environment

SAP Business bydesign

Reproducing the Issue

  1. Go to New Business Work center
  2. Go to Sales Quotes View
  3. Search for Sales quote ID 
  4. Select sales quote ID and send for approval

Log on to SAP Business Bydesign Mobile app, try to approve the sales quote and you can see the error "Enter an e-mail address in the output settings" and the sales quote is not approved.

Cause

In ByD UI it is system behavior that it is allowed to support mass approval (Selecting and approving multiple sales quote and all other documents) which Ignore the validation errors.

However, in mobile mass approval process is not there hence the behavior is different in Mobile and UI. If there is any error during the sales quote approval in mobile then the error should be resolved by the user

Resolution

This is expected current system behavior.

In case if then expectation is to have ByD UI behavior same as Mobile UI, then provide your feedback in Customer Influence forum https://influence.sap.com/sap/ino/#/campaign/886

Keywords

sales quote approval, mobile, byd ui, output settings , KBA , SRD-CC-MOB , Mobile Framework , Problem

Product

SAP Business ByDesign all versions