Symptom
Activity Task are created in an Activity List.
Status of an Activity List is not set to "Active” before the activities, like tasks are created.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Activities work center.
- Go to Activity lists work center view.
- Click on + icon to create Activity List.
- In Type field select "Task List".
- Status defaults as "In Preparation".
- Fill in required details which includes details of the Tasks list like due date, subject, etc. and set Owner Determination - yes.
- Click on Save.
- Activity List is created.
- Open this created Activity List.
- Go to Overview facet.
- Click on "New" and click on Select Accounts.
- Select the Account from the pop up.
- Click OK.
- Status of Activity List is "In preparation", even though the tasks gets assigned to the account owner.
Expectation: Activity list status should change to Active and then the tasks list get assigned to the owners of the account.
Cause
Status of Activity List does not Change to "Active" and stay "In preparation" to allow changes done on the Tasks created in Activity List.
Resolution
Status of an Activity List stays with status "In Preparation" and not set to Active, before the activities like tasks gets created. This is current and behaviour.
Also note the following: -
- Task in Activity List can be changed if the status of an Activity List is "in preparation".
- Once the Activity List is Changed with Status "Active", no changes are allowed in List.
- Should there be any changes done for an existing Activity list, the status must be set to "In preparation".
Keywords
Activity list, task, in preparation, active, Task activity , KBA , LOD-CRM-ACT , Activities , Problem
SAP Knowledge Base Article - Public