SAP Knowledge Base Article - Public

3493540 - Service Order Remains in the "Completed" Status Even After the Cancelation of Follow-up Documents Like Service Confirmation In Third Party Scenario.

Symptom

The Service Order remains in Completed status though the line item in the related Service Confirmation are already Canceled.

You expect the status of the Service Order to be In Process in the Third Party Repair Process.

Environment

SAP Business Bydesign

Reproducing the Issue

  1. Go to Service Orders work center
  2. Go to Service Order Processing and search for order XYZ(XYZ is The ID of the Service Order)
  3. You can see the service order is completed, with service status is finished
  4. However, the corresponding Service Confirmation YYY is cancelled with reason for rejection and the same is not updated in the Service Order.(YYY is the ID of the Service Confirmation)

Cause

In Third Party Service scenario, cancelling the Service Confirmation will not update cancellation status in Service Order unless you cancel the corresponding Purchase Order.

Resolution

Kindly cancel the corresponding Purchase Order, post which the Service Order delivery status will be updated to In Process and Service Order status will be set to In Process from Completed.

Keywords

Service Confirmation, Cancel, reason for rejection, third party , KBA , SRD-CRM-SEO , Service Orders , Problem

Product

SAP Business ByDesign all versions