SAP Knowledge Base Article - Public

3494045 - Knowledge Base Integration with Microsoft SharePoint search showing all data from SharePoint- AskHR

Symptom

You have integrated SharePoint with Ask HR for Search KBA functionality but whenever you search for any KBA with a keyword it returns documents that does not seems to be relevant for your search, whereas other documents more relevant are not returning or returning at the end of the search.

Environment

  • SAP SuccessFactors HXM Suite
    • Employee Central
      • Ask HR - Employee Central Service Center (ECSC)
        
      

Reproducing the Issue

Steps to reproduce the issue:

  1. Open AskHR and click on "Search Knowledge base" box.
  2. search with any keyword for example: "benefit" and click on search button.
  3. It will return you results which seems are not related to your search

Cause

Expected Behavior.

The reason behind it is a mix of how the search engine in Sharepoint works and also how AskHR sends the search.

Starting with Sharepoint what happens is that your keywords being searched are applied in the context of the document, this means that not only the title of the document is taken into consideration but the whole document content.

So if you search by a single word, the chances that this word also appears in other documents not directly related and then returned are big.

Finally we have the way how AskHR searches these documents, currently the AskHR search engine orders the results per last modified, this means that then you send a key word, the document will search all matching records and then sort it to show the most recent documents changed at the top.

Adding both behaviors together, means that if you search by a very common word, chances are that you will receive not relevant documents for your need if they were recently changed. 

Resolution

If you wish to change or improve this behavior, please feel free to suggest an enhancement request.

2090228 - How to submit enhancement ideas for SAP SuccessFactors Products

See Also

Configuring Microsoft SharePoint Online as a Knowledge Base | SAP Help Portal

Keywords

ECSC, AskHR, SharePoint, MicroSoft, Knowledge base integration, KBA, random result, all KBAs, Knowledge Base Integration with Microsoft SharePoint, Integration. , KBA , LOD-SF-INT-AHR , Ask HR - Employee Central Service Center (ECSC) , Problem

Product

SAP SuccessFactors HXM Suite 2311