Symptom
You are able to add same Registered Product as a covered object for multiple Active Contracts but you expected an error instead and expected one Registered Product to be linked as a covered object for only one active contract.
Environment
SAP Cloud for Customer core applications
Reproducing the Issue
- Go to Contracts Work Center
- Click on New Contract
- Create a new Service Contract ABC (ABC represents the Contract ID)
- Go to Covered Objects Facet
- Click on Add
- Add a Registered Product with Serial ID 123 (123 represents the Registered Product Serial ID)
- Click on Save
- Click on Action and Activate Contract
- Create another Service Contract DEF ( DEF represents the Contract ID)
-
Go to Covered Objects Facet
-
Click on Add
-
Add Registered Product with Serial ID 123 (123 represents the Registered Product Serial ID)
- Click on Save
- Click on Action and Activate Contract
You notice that the save was successful but you expect an error and save to be unsuccessful since you are using same Registered Product for different Active Contracts.
Cause
It is not limited to have several Active Contracts for one Registered Product from standard C4C functionality. Hence there is no error on using same Registered Product for multiple Contracts.
Resolution
If the feature/functionality is needed as a matter of urgency, please refer to KBA 3475641 - Functionality Currently not Available.
Keywords
Contract , Registered Product , Same , Multiple , Active , Error , Covered Objects , Add , New , KBA , LOD-LE-COP-SRV , Service Contract , LOD-LE-IBA-IPO , Installation Point , How To