SAP Knowledge Base Article - Public

3494307 - No Error Message Is Displayed On Using Same Registered Product For Multiple Active Contracts

Symptom

You are able to add same Registered Product as a covered object for multiple Active Contracts but you expected an error instead and expected one Registered Product to be linked as a covered object for only one active contract.

Environment

SAP Cloud for Customer core applications

Reproducing the Issue

  1. Go to Contracts Work Center
  2. Click on New Contract
  3. Create a new Service Contract ABC (ABC represents the Contract ID)
  4. Go to Covered Objects Facet
  5. Click on Add
  6. Add a Registered Product with Serial ID 123 (123 represents the Registered Product Serial ID)
  7. Click on Save
  8. Click on Action and Activate Contract
  9. Create another Service Contract DEF ( DEF represents the Contract ID)
  10. Go to Covered Objects Facet
  11. Click on Add
  12. Add Registered Product with Serial ID 123 (123 represents the Registered Product Serial ID)
  13. Click on Save
  14. Click on Action and Activate Contract

You notice that the save was successful but you expect an error and save to be unsuccessful since you are using same Registered Product for different Active Contracts.

Cause

It is not limited to have several Active Contracts for one Registered Product from standard C4C functionality. Hence there is no error on using same Registered Product for multiple Contracts.

Resolution

If the feature/functionality is needed as a matter of urgency, please refer to KBA 3475641 - Functionality Currently not Available.

Keywords

Contract , Registered Product , Same , Multiple , Active , Error , Covered Objects , Add , New , KBA , LOD-LE-COP-SRV , Service Contract , LOD-LE-IBA-IPO , Installation Point , How To

Product

SAP Cloud for Customer core applications all versions