SAP Knowledge Base Article - Public

3494646 - Unable to find and re-trigger the I-9 workflow after declining to sign the Section 3 form - Onboarding

Symptom

  • After selecting the "decline" option in the signature window, the task disappears and cannot be located or triggered again.
  • When trying to manually trigger I-9 workflow, an error appears, "The previous sections of Form I-9 are incomplete for the selected user. Please complete them to proceed.".

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  1. Go to Manage Data.
  2. From the Create New dropdown, select ‘Trigger I-9 Flow’.
  3. Trigger the I-9 workflow for the candidate.
  4. An error appears "The previous sections of Form I-9 are incomplete for the selected user. Please complete them to proceed."

Cause

This is a Known Issue.

Resolution

This issue will be corrected in the 2H 2024 Release. Release dates can be found on SAP SuccessFactors Product Release & Road Map Information.

WORKAROUND:

Please generate the link by using the following format:

https://hcm8preview.sapsf.com/sf/onboarding2/compliance/i9section3?encryptedUserId=XXX&bpeUserTaskId=XXX

Just have to replace parameters encryptedUserId and bpeUserTaskId, these parameters can be obtained from BPE: Monitor process of affected candidate.

Keywords

OBX-31708, decline, decline the Section 3, Reverification Error, Trigger I-9 workflow, signature , KBA , LOD-SF-OBX-I9 , i9 Compliance Form , Known Error

Product

SAP SuccessFactors Onboarding all versions