SAP Knowledge Base Article - Public

3494648 - Manage My Timesheet - Employment doesn't exist, is inactive or you do not have authorization

Symptom

When opening app 'Manage My Timesheet', user receives error 'Employment doesn't exist, is inactive or you do not have authorization'.

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

SAP S/4HANA Cloud, Public Edition

Reproducing the Issue

  1. Login as the affected user;
  2. Open app 'Manage My Timesheet';
  3. Notice that the error message 'Employment doesn't exist, is inactive or you do not have authorization' will be displayed.

Cause

The worker trying to access app 'Manage My Timesheet' does not have an active Work Agreement.

Resolution

For a worker to be able to access app 'Manage My Timesheet' and/or book time, this user must have an active Work Agreement. Such information can be checked in app 'Manage Workforce', by searching for this specific employee.

A step by step orientation on how to create a Work Agreement can be found in the following link: SAP Help Portal - How to Create and Correct Work Agreements.

See Also

Also, for further information on this error message, check KBA 2740764 - Manage My Timesheet app - Fatal error occurred during processing.

Keywords

S/4HANA Cloud, timesheet, manage my timesheet, employment, employment doesn't exist, worker, work agreement, fatal error, 2740764 , KBA , CA-TS-S4 , Cross Application Timesheet in S/4HANA , Problem

Product

SAP S/4HANA Cloud Public Edition all versions