SAP Knowledge Base Article - Public

3494762 - Extension Fields Configured Via PDI Solutions Do Not Appear in The Drop Down For Code-List Restrictions.

Symptom

While configuring code-list restrictions, extension fields configured via PDI solutions do not appear in the Drop Down for Code to Restrict/Control field.

Environment

SAP Cloud for Customer

Reproducing the Issue

1. Login to C4C.

2. Go to General Settings -> Code list restrictions.

3. Click on "New", select any Business Object. (The Business Object here should be the one for which you have created the Extension fields via PDI Solutions)

4. Click on the "Code To Restrict" drop down.

5. Notice that the extension fields do not appear (in this case "Test Extension Field")

Cause

Since these fields are added via PDI solution, they will appear in the Code to Restrict/Control Field drop down as shown below. (basically it would contain prefixes before the actual field name)

Original - Test Extension Field (if the "Test Extension Field" is part of the Original Solution)

Patch - Test Extension Field (if the "Test Extension Field" is part of the Patch Solution)

Resolution

This is an expected system design with respect to Extension Fields added via PDI Solutions.

Keywords

PDI Solution, Code List restriction, Extension Fields, Fields do not appear, Control field, Code to Restrict , KBA , LOD-LE-RC-CLR , Code List Restriction , Problem

Product

SAP Cloud for Customer core applications all versions