SAP Knowledge Base Article - Public

3495109 - Surveys tab is not visible for Visits

Symptom

It was noticed that some Visits have the Surveys tab available while others do not, even though the Surveys facet is set as visible in adaptation mode.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Visits > Visits;
  2. Open Visit ABC (while ABC represents the ID number);
  3. See there is no Surveys facet there;
  4. Now open Visit DEF (while DEF represents another ID number);
  5. Surveys tab is shown.

Cause

The affected Visit is a Perfect Store Visit.

C4C has standard logic for visibility property for the Task, Survey, and Visit Execution missing tabs where they will only be visible if Visit is not a Perfect Store Visit. If Visit is Perfect Store Visit then worklist items (task, survey) will not be enabled.

Resolution

This is the system expected behavior.

If the feature/functionality is required urgently, please refer to KBA 3475641 - Functionality Currently not Available.

Keywords

cannot be seen, can't see, cannot find, can't find, cannot be found, not showing, disappears, not appearing , KBA , LOD-CRM-ACT-VST , Visit Planning , LOD-CRM-OPP , Opportunity Management , LOD-LE-SUR , Survey , Problem

Product

SAP Cloud for Customer core applications all versions