SAP Knowledge Base Article - Public

3495120 - SAP Marketing Segmentation - Usage of Account Attribute Filters

Symptom

In SAP Marketing Segmentation in the B2B context you consume different account attributes in as segmentation filters - you are however unsure about the result.

Environment

  • SAP Marketing On-Premise
  • SAP Marketing Cloud Edition

Reproducing the Issue

  1. Create a segmentation model from segmentation profile 'all contacts' and 'all accounts and contacts'
  2. Consume different 'industry' attributes as a filter


  3. Observe different results depending on the segmentation profile and the industry filter used

Cause

The design is depending on the underlying segmentation object. The segmentation profile 'all contacts' consumes the segmentation object 'contacts' (SAP_CONTACT_ENGAGEMENT_SIN), whereas the segmentation profile 'all accounts and contacts' consumes the segmentation object 'accounts and contacts' (SAP_CE_INTERACTION_CONTACT). Both segmentation object are created for the B2B context but follow different design which results in different filter attributes available on contact and account level.

Resolution

Please consider the following design when consuming each of the segmentation objects:

  • segmentation object 'contacts' (SAP_CONTACT_ENGAGEMENT_SIN)

    The segmentation object returns contacts (persons) only. The segmentation object however provides contact and account attributes as filters, the result of the segmentation model however is always contacts - in other words, segmentation returns contact but not accounts. When using account attributes, the contact-account reference is done via the relationship, so accounts without having any contacts assigned won't be processed by segmentation.


    Based on that design depending on the contact or account attribute, segmentation returns the following data: 
    • contact attribute - example 'industry' (attribute BRSCH)
      filter: 'industry eq software'
      => return all contacts from software industry (the filter checks the industry on contact level)
    • account attribute - example 'industry' (attribute KNA1_BRSCH)
      filter: 'industry eq software'
      => return all contacts of accounts from software industry (the filter checks the industry of the account and returns all contacts of those accounts)

  • segmentation object 'accounts and contacts' (SAP_CE_INTERACTION_CONTACT)

    The segmentation object returns both objects, accounts and contacts. As accounts and contacts are returned, the filter is executed on the object directly, so the filter is processed on the contact (person) or the account directly. The segmentation object does not consider the contact-account reference but returns each of the objects.



    • attribute - example 'industry' (attribute BRSCH)
      filter: 'industry eq software'
      => return all contacts and accounts from software industry (the filter checks the industry interaction contact, contact (person) and account level)

See Also

Please also refer to the following help link:

Keywords

Segmentation Model, Contacts, Accounts, Relationship, Contact Person Rel.ship
Segmentatierungsmodell, Kontakte, Kunden, Beziehung, Ansprechpartnerbeziehung
Modèle de segmentation, Contacts, Comptes, Relations, Relation contact , KBA , CEC-MKT-SEG , Segmentation , CEC-MKT-DM-SEG , Segmentation Profiles for DM , Problem

Product

SAP S/4HANA Cloud Public Edition all versions

Attachments

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