Symptom
You need to Update Responsible Employee for Customers Via Mass Data Maintenance.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to Mass Data Maintenance work center
- Click on Import Customers Link
- Upload the file template.
- Update Responsible Employee Via Mass Data Maintenance for Customers/ Accounts.
- However when we run the file it does not replace the previous responsible employee but creates a new one, so the customer is left with two responsible employees.
Cause
For the mass update / migration the node for the direct responsible cannot be identified (missing visible ID), therefore we cannot change, but only add.
Resolution
What could be done:
Query all direct responsible for the account via FIND_ACCOUNTS web service, then change the complete list of direct responsible to have what you need.
Use the MANAGE_ACCOUNTS web service to update the complete list at once.
Keywords
Mass Data Maintenance, Responsible Employees, Customers, Business ByDesign , KBA , SRD-CC-MIG-CNT , Migration: Content , SRD-CRM-ACC , Account Management , How To