SAP Knowledge Base Article - Public

3497088 - Workspace admin is getting error "Unknown e-mail address" when inviting external users. 

Symptom

Workspace admin tried to invite external user in a newly created workspace but it is not working and giving an error "Unknown e-mail address" when putting the email address of the external user to the invitation page.

Environment

SAP SuccessFactors Work Zone

Reproducing the Issue

  1. Go to workspace with external flag
  2. Click on invite
  3. Invite e.g. user "abc@def.com"
  4. Error  "Unknown e-mail address" will appear

Cause

Allow external users to access this workspace and be invited as members is not selected in workspace admin settings.

Resolution

1. In the workspace settings make sure that the option Allow external users to access this workspace and be invited as members is selected. You can choose this option when you create a workspace or when you edit an existing workspace, as long as the company workspace settings allow this.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

2. Click +Invite at the top of the workspace.

3. In the Invite Workspace Members screen, enter the external user email, a personal message (optional), and click Send.

If the external user email doesn't exist in the external users list (available to company administrators in the Admin Console), the following error is displayed: "Unknown e-mail address".

See Also

3443513 - "Delegate to area admin" option for external Workspace
How to Invite External Users to a Workspace

Keywords

External user, wz, Work Zone, private, external user, company admin, Workspace, Workspace invite, Workzone, email , KBA , LOD-SF-SWZ-ADM , Admin Access , Problem

Product

SAP SuccessFactors Work Zone 1.0

Attachments

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