SAP Knowledge Base Article - Public

3497877 - Unable to change user attribute in SSO configuration in the SAP Analytics Cloud (SAC) ?

Symptom

Not able to change the user attribute in SSO configuration in SAC. 

Environment

SAP ANALYTICS CLOUD

Reproducing the Issue

  1. Login to SAC using system owner account. 
  2. Go to System>security 
  3. Try to change the user attribute. 
  4. You will need to upload the new metadata file. 
  5. In General Data > Name shows the below screen: 



    Notice that you will not be able to change the user attribute. 

Cause

System is currently using the ID which is already in use. 

Resolution

To change the user attribute for SSO configuration in SAC:  

  1. Revert your custom IdP to default. 

    It is recommended to revert the IdP through the IdP tool cause when doing from UI sometimes it gets stuck. You can refer the below KBA for reverting the IdP through IdP tool:
    2908073 - How to use the IdP Admin Tool to make changes to IdP Configuration in SAP Analytics Cloud when no access is available to the tenant  
    https://me.sap.com/notes/2908073 

  2. Configure SSO again and this time we can make changes in the user attribute as per requirement. 

    Refer to the below documents to set the SSO: 
    https://help.sap.com/docs/SAP_ANALYTICS_CLOUD/2d7115b0e0aa4f78bfd9c06fdc1fe4f6/93fbc016bc9348e088bb486b4dc500f9.html

    https://community.sap.com/t5/technology-blogs-by-members/sso-setup-for-sap-analytics-cloud-using-external-identity-provider/ba-p/13547400#:~:text=Pre%2DRequisite%20to%20Configure%20SSO%20with%20External%20Identity%20Provider%20in%20SAC.&text=From%20the%20side%20navigation%2C%20go,Identity%20is%20used%20for%20authentication.

See Also

Keywords

user, attribute, SSO, IdP, custom, default, change, direct, tool, system, Id , KBA , LOD-ANA-AUT , SAC Authentication / Login , Problem

Product

SAP Analytics Cloud 1.0

Attachments

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