SAP Knowledge Base Article - Public

3498102 - System automatically removes the Contact's Job Title, Mobile, Phone and Email

Symptom

System automatically removes the Contact's Job Title, Mobile, Phone and Email when we delete the 'Main' Related Account

Environment

SAP Sales Cloud and SAP Service Cloud Version 2

Reproducing the Issue

  1. Open the Navigation Menu
  2. Open Contacts  
  3. Open any Contact
  4. Delete the 'Main' Related Account in the Related Accounts section
  5. System automatically removes the Contact's Job Title, Mobile, Phone and Email etc.

Cause

This is because of the current system design. When we open Google Chrome dev tools, we can see that in the GET call for the Contact, these fields are associated to "isContactPersonFor". Therefore, when this is deleted, there is no association anymore, so no data. 

Resolution

This is the expected system behaviour.

See Also

main account, job title, mobile, phone, delete

Keywords

KBA , CEC-CRM-CON , Contact for SAP Sales/Service Cloud , Problem

Product

SAP Sales Cloud and SAP Service Cloud Version 2 1.0