Symptom
When attempting to search for multiple users using uppercase letters, the search does not return the usernames. However, if the search is conducted using lowercase letters or the exact username, all users are displayed correctly.
Reproducing the Issue
1. log in to instance
2. Navigate to manage calibration session
3. Open any Calibration session (ex:- Test Calibration session)
4. Navigate to people tab and search the user based on username
5.Try to find multiple user in uppercase letter and you will see there is no data present.
Cause
It is designed by the system. You can search for a single user using uppercase letters, but not for multiple users
Resolution
This is an expected behavior.
-
Multiple Usernames (Start With or Exact Match):
- The backend adopts an exact match approach regardless of case sensitivity. For instance, if a username is in uppercase and the input is in lowercase, the search will not return results. For example, if the input is 'SFADMIN,CBRAUN', it will be set as
IN ('SFADMIN', 'CBRAUN')
in the SQL search. Therefore, the users will not be found if the cases do not match exactly.
- The backend adopts an exact match approach regardless of case sensitivity. For instance, if a username is in uppercase and the input is in lowercase, the search will not return results. For example, if the input is 'SFADMIN,CBRAUN', it will be set as
-
Single Username (Start With):
- For a single username, a fuzzy match with lowercase is adopted. For instance, if the input is 'SFADMIN', it will be set as
LIKE 'sfadmin%'
in SQL. This means the user will be found regardless of the case.
- For a single username, a fuzzy match with lowercase is adopted. For instance, if the input is 'SFADMIN', it will be set as
To support case-insensitive behavior for multiple usernames, you can raise an enhancement request.
Keywords
calibration, calibration people, username, lowercase, uppercase, people tab, people search , KBA , LOD-SF-CAL-SES , Sessions, Creating, Managing etc. , Problem
Product
Attachments
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