Symptom
- Error occurred when user try to resolve an E-Verify case from Create E-verify Case page.
- Error message: "The user does not have permission to EverifyData".
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Login as E-verify responsible user and go to "Create E-verify Case" page;
- Enter the employee's name in the search bar;
- Click on Resolve > select the close reason;
- Click on Resolve > An error comes up: "The user does not have permission to EverifyData".
Cause
The E-verify case that the user wants to manually resolve was created in the candidate's onboarding process.
The "Create E-verify Case" page has now changed as part of 1H 2024 release to allow Hiring Managers to upload new Form I-9s and create new E-Verify cases;
This should not be used to manage existing E-Verify Cases. Those should still be managed through the Dashboard or the associated home page cards/To-Do tiles.
Resolution
The "Create E-verify Case" page is currently only used for manually creating and handling E-verify cases that don't have an onboarding process, hence the error is expected.
Keywords
Create E-verify Case, reslove E-verify, the user does not have permission to EverifyData, E-verify permission, E-verify error, close E-verify, EverifyData, permission to EverifyData , KBA , LOD-SF-OBX-EVF , Everify , Problem