SAP Knowledge Base Article - Public

3498578 - The username token in the external welcome email is not being valued correctly - Onboarding

Symptom

The username token in the external welcome email is not being valued correctly.

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

1. Initiated onboarding;

2. External welcome email was sent to the new hire;

3. The username in the email is displayed as the new hire's personal email address while it should be user id according to the configuration.

Cause

The person-id-external has been synced with the username via Manage Business Configuration > HRIS Sync Mappings.

From an onboarding perspective, the candidate's username is the personal email address during the initiation of onboarding. Since there is no new hire data review step in the onboarding flow, the external welcome email is triggered immediately after onboarding initiation, using the personal email address as the username, as expected.

After that, the HRIS Sync is executed, and the candidate's username is synced to the user ID once the external welcome email is triggered. This is how the system currently works.

Resolution

For Onboarding, ideally the USERNAME only changes after the start date even when Manage Pending Hires is completed.

Please remove the HRIS Sync Mapping for username because it will cause the candidate login issue.

See Also

2922920 - Change username during Onboarding process - Onboarding

Keywords

welcome email, username token, username, email username, hris mapping, person-id-external , KBA , LOD-SF-OBX-EML , Notifications , Problem

Product

SAP SuccessFactors Onboarding all versions