SAP Knowledge Base Article - Public

3498706 - Is it possible to revert back to the previous version of a Survey?

Symptom

When creating Surveys, it is needed to get back to the previous version of a Survey. For example, it was created a Survey that is in version 5, but it is now needed to get back to version 4 to be used instead of the current one.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Surveys > Surveys;
  2. Open the desired ID;
  3. It should be activated the previous version of this Survey.

Cause

Once a new version of a Survey is created, all the previous versions become inactive and only the current one is Active to be used.

When the Surveys are inactivated, it is impossible to perform a change (via UI, backend or DWB) as it can lead to inconsistencies in the system. It involves another BOs that could affect master data and that is why this is not feasible via SAP standard methods.

Resolution

This is the expected behavior.

However, it is possible to copy the data from the inactive Survey (the desired previous version) manually to a new version. So the new copied Survey will have the data from the previous Survey.

This should be done manually as it is currently not possible to do massively via standard.

 

For a different behavior, please post a new request in our Influence Site. This is the channel to approach our product management team directly. They will evaluate the feasibility of the request and provide an statement on the possibility of enabling it on a future release. Our product management team is constantly seeking for ideas for new features.

See Also

SAP Help: Survey Statuses

Keywords

KBA , LOD-LE-SUR , Survey , Problem

Product

SAP Cloud for Customer core applications all versions