SAP Knowledge Base Article - Public

3498745 - Contact Is Not Being Synchronized To Outlook Using Server Side Integration Add-in

Symptom

 Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental." 

The contact "ABC" was added to "Example 1" account, however the "ABC" contact is not being synchronized to "User A" on his Outlook using Server Side Integration, event the "User A" being the "Example 1" owner under "Account Team" facet.


Environment

SAP Cloud for Customer

Reproducing the Issue

1. Go to Customers work center.
2. Open the Accounts work center view.
3. Search for "Example 1" account.
4. Go to the account team facet.
5. The "User A" user is the Account Team.
6. Go to contacts facet.
7. The "ABC" contact is appearing on Contacts facet.
8. Go to user "User A" Outlook to check and the "ABC" contact is missing.

Cause

The contact was not synchronized because it was not returned from the CRM API when searching for existing objects for synchronization.
Please note that the client has a limit of 4500 objects (as an example) set for contacts.

Resolution

Accordingly, we will only request the first, 4500 objects (the total limit for all object types like Contact + Individual Customer + Account cannot exceed more than 9.000).

Therefore, even if the limit is increased and the contact is not returned (for example, if it's sequential number in CRM is greater than the limit set for contacts in customization), such an object will not be synchronized, as it will also not be returned in response to the corresponding request.

If the customization management is allowed for the user and the limits set on the user level is different from the value in the Profile, the value from the user level will be respected.
The logic remains as initially implemented. 

See Also

How are Contacts linked to Accounts during synchronization?

SSI links Contact to an Account in SAP Cloud for Customer if Contact’s “Company” field in MS Outlook contains the Account name. Server-Side Sync performs a search for an Account in CRM:

if there is a match, Contact will be linked to an existing Account in SAP Cloud for Customer
if there is no match, SSI will try to create an Account in SAP Cloud for Customer
if a failure occurs, Contact will be saved to SAP Cloud for Customer without company

Known synchronization errors

Synchronization engine:

A limit on the number of snapshot records is exceeded (10000/10040/0).

C4C Server side Integration with Microsoft Outlook

Limit for objects which are synched is 10.000.
The creation date is considered.


Keywords

Sync; Synchronization; Contact; Server Side; Groupware; Add-in; Outlook; C4C; Owner; Missing; SSI , KBA , LOD-CRM-GW-SCC , Invisible CRM - Smart Cloud Connect Solution , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications 2405

Attachments

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