Symptom
- Insurance Benefits are configured in the system. In the Insurance Plan Configuration, Eligibility Rule is maintained
- When enrolling users via Benefits Overview, the corresponding Insurance Plans are displayed as expected
- However, when an admin tries to edit the Benefit Enrollment record via Manage Data, when reselecting the Insurance Plan field, no plans are displayed
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SAP SuccessFactors Employee Central - Global Benefits
Reproducing the Issue
- Go to Manage Data or Benefits Admin Overview > Benefit Enrollment
- Open the record > Make Correction or Insert New Record
- Update the Insurance Plan field
- No results displayed
Cause
Insurance Plan Eligibility Rule is ran against the login user's data in Manage Data UI. Hence, if the user's data does not meet the criteria in the rule, the corresponding plans are not displayed. The behavior is different in Benefits Overview UI where the rule is ran against the employee's data.
For example, if we remove the Eligibility Rule, the plan will be visible again on edit.
View in Manage Data.
Resolution
As a workaround, the Eligibility Rule needs to be reviewed such that the conditions used will also meet an admin's data.
For example:
Keywords
insurance plan, eligibility rule, manage data, not visible, displayed, there were no results , KBA , LOD-SF-EC-GBF , Global Benefits , Problem