SAP Knowledge Base Article - Public

3499302 - Calendar selection not working - Employee Central

Symptom

When trying to select a date in the calendar for a change in a portlet of the employee profile, the calendar is not navigable.

Environment

SAP SuccessFactors Employee Central

Reproducing the Issue

  1. Go to portlet;
  2. Start to create or edit a record;
  3. Select calendar date;
  4. Unable to navigate.

Cause

There is a custom translation in Manage Language for key ECT_PP3_MMMDDYYYY in the selected locale with an invalid character. 

Resolution

  1. Go to Manage Languages;
  2. Download Custom translations for locale;
  3. In the file, search for ECT_PP3_MMMDDYYYY;
  4. Delete this row and save file;
  5. Upload file in custom translation;
  6. Check if issue persists. 

Note: by deleting the rows, the default translation will be respected. If you wish to change to yet another translation, you can keep the row in the file and upload with the desired text order. 

See Also

Keywords

calendar picket, calenda selection, incorrect date selection, date issue, calendar issue, locale issue, INC8907877,  , KBA , LOD-SF-EC-PER-NAT , National ID - Config, Rules, RBP, UI , LOD-SF-PLT-LAN , Manage Language & Text Replacements , Problem

Product

SAP SuccessFactors HCM Core 2405