SAP Knowledge Base Article - Public

3499342 - Apps cannot be found after adding the according Business Catalog - SAP S/4HANA Cloud Public Edition

Symptom

Apps cannot be found or are not available/searchable even if the required Business Catalog is included in the Business Roles assigned to user.

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. Search information about the desirable app in the SAP Fiori Apps Reference Library (ondemand.com).
  2. Add the according Business Catalog in the Business Role.
  3. Assign the Business Role to user.
  4. The app cannot be searched/found .

Cause

There are two possible causes for this issue: 

Cause 1:

The Application Category of the app is Standard Navigation Target (T), which means the app in the catalog does not show as a tile and the app cannot be accessed directly. The app can only be accessed by the navigation from other apps.

Cause 2:

Application is not active in the Business Role inside the "IAM Apps" tab.

In Maintain Business Roles app you can control the access to your applications by combining predefined business catalogs. If the business catalogs support IAM apps, they bundle app authorization variants. You have the option to activate/deactivate individual IAM apps according to your business requirements. This allows you to assign only the apps that are required for a business role to it giving you the flexibility to manage authorizations for business users on a more granular level. 

If the app that you're looking for is not active, you'll not be able to find it in your system even with the role assigned. 

In order to find this information, follow the steps below:

  1. Go to Maintain Business Roles app
  2. Open the Business Role 
  3. Go to "IAM Apps" tab 
  4. Search for the application and scroll to the right 
  5. Find the "Active" column
  6. If there's a flag in this column, the app is active. Otherwise, it's not.

Resolution

Solution 1:

Check the Applications - Business Catalogs tab in app "IAM Information System" by searching the app name with "Application" set in the filter "Main Entity".

Check the Application Category:

  1. If the Application Category shows Standard Application (S), it means that the app can be accessed directly in this Business Catalog.
  2. If the Application Category shows Standard Navigation Target (T), it means that the app cannot be accessed directly and can only be accessed by the navigation from other apps in this Business Catalog.

Therefore, another Business Catalog can be used with the Standard Application (S) in Application Category as a substitute.

Solution 2:

If the application is inactive, follow the steps below:

  1. In Maintain Business Roles app, open the Business Role
  2. Click on "Edit"
  3. Go to "IAM Apps" tab 
  4. Search for the application
  5. Select the Authorization Variant related to the application 
  6. Click on "Activate"
  7. Save the role

See Also

For more information regarding IAM Apps, check How to Activate or Deactivate IAM Apps of Type App Authorization Variant.

Keywords

Cannot find app, app is not searchable, Application Category, Navigation Target, Business Catalog, IAM Information System , KBA , BC-SRV-APS-IAM , Identity and Access Management , Problem

Product

SAP S/4HANA Cloud Public Edition all versions