SAP Knowledge Base Article - Public

3499639 - E-mail got Triggered for Archived Opportunity

Symptom

When archiving an Object, for example Opportunity, Workflow Rule e-mail got triggered.

This behavior applies to any other document.

Environment

SAP Cloud for Customer

Cause

For Workflow Rules of Type 'E-mail' and Schedule as 'On Every Save', when archiving an Object the Workflow will trigger as the Save button is used to archive it. After the archiving, the rule won't be triggered as the object will become inactive and not be used anymore.

Resolution

This is the expected system behavior. 

For any different behavior on this matter, please post your request in our Influence Site. This is the channel to approach our product management team directly. They will evaluate the feasibility of the request and provide an statement on the possibility of enabling it on a future release. Our product management team is constantly seeking for ideas for new features.

Keywords

Sales Order, Sales Quote, Lead, Ticket, Campaign, Target Group, Activity, Task, Appointment, Phone call, Visit, Customer, Client, Account, Individual Customer, Contact, Employee , KBA , LOD-CRM-OPP , Opportunity Management , LOD-CRM-WKF , Workflow , LOD-CRM-ARC , C4C Archiving , Problem

Product

SAP Cloud for Customer core applications all versions