SAP Knowledge Base Article - Public

3499792 - Language Adaptation is Not Working in SAP Sales Cloud Mobile App

Symptom

You have maintained a label using Language Adaption, but incorrect label is shown for specific field in SAP Sales Cloud Mobile app.

Environment

  • SAP Service Cloud v2
  • SAP Sales Cloud v2

Reproducing the Issue

  1. Login to SAP Sales cloud app. Make sure the language of your device is set to the one you adapted with Language Adaptation.
  2. Click on More (menu button).
  3. Navigate to any view.
  4. Click on + button.
  5. Notice it shows incorrect label for a field.

Cause

Incorrect field was changed in language adaptation.

Resolution

  1. In desktop, click on profile icon.
  2. Go to Settings.
  3. Open language adaptation screen.
  4. Select affected application.
  5. Select Source and Target language.
  6. In basic search, look for the label that is shown in the mobile app.
  7. For the affected label ID, change the target language text to the wanted value.
  8. Click on save.

Keywords

Mobile, Label, Language Adaptation, Translation , KBA , CEC-CRM-TXA , Text Adaptation , How To

Product

SAP Sales Cloud and SAP Service Cloud Version 2 1.0