Symptom
When creating a new campaign, the user who created it is automatically assigned and displayed as the responsible employee for the campaign. But the responsible employee can no longer be changed.
The corresponding field on the user interface cannot be edited and no change to a different employee ID can be made via the Data Workbench either.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Sales Campaigns > Campaigns;
- Create a new Campaign;
- The current user will be assigned as the Owner;
- Try to edit it;
- Owner field cannot be edited.
Cause
The Owner field is the one who created the campaign from marketing view and cannot be changed. Users can use field 'Employee Responsible' instead. This field can be edited and changed, which means the employee who is going to be responsible for the sales campaign in future.
Resolution
This is the expected system behavior.
For a different behavior, please post your request in our Influence Site. This is the channel to approach our product management team directly. They will evaluate the feasibility of the request and provide an statement on the possibility of enabling it on a future release.
Keywords
KBA , LOD-CRM-MKT-CAM , Campaigns , LOD-CRM-OPP , Opportunity Management , Problem