Symptom
Close date is not updating automatically, based on the status change in Opportunity.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Sales work center.
- Go to Opportunities work center view.
- Search and open any opportunity.
- Click on Edit button.
- In Header, change the Status field "In progress" to "Stopped".
- Date in Change Date field does not update automatically to current date.
- Expectation: Change Date should change to current date.
Cause
In Business Configuration of implementation project, following question is not scoped for opportunities. This is relevant for updating the Close date of an opportunity when status is set to Stopped.
"Do you want to automatically set the close date of an opportunity to the current date once the opportunity life cycle is set to Stopped?
Resolution
Review/Checked scoping question "Do you want to automatically set the close date of an opportunity to the current date once the opportunity life cycle is set to Stopped?" leads to close date of an opportunity to the current date, once the status is set to Stopped.
Execute steps mentioned below to review/check the scoping question associated:
- Go to the Business Configuration work center.
- Go to the Implementation Projects view.
- Select the Current project.
- Click on Edit Project Scope.
- Go to the Questions tab (step 4).
- Expand Scoping Element Sales.
- Select New Business.
- Select Opportunities.
- Select to review/ check the question "Do you want to automatically set the close date of an opportunity to the current date once the opportunity life cycle is set to Stopped?".
- Save the changes.
- Go forward and click 'finish'.
- Refresh the page.
Keywords
Opportunities, Status, Stopped, Close date, Sales, Scoping question, scope. , KBA , LOD-CRM-OPP , Opportunity Management , Problem