Symptom
- Getting an error when trying to initiate background check with the vendor HireRight.
- Error: "Unable to initiate background check. Reason: Network Error".
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
- Go to Recruiting > Job Requisition and open a job application
- Select Initiate Background Check with the vendor HireRight
- An error pops up "Unable to initiate background check. Reason: Network Error"
- Go to Integration Center and open the HireRight background check integration
- Go to "Review and Run" tab
- Click on the "Last Run Time"
- Check the event log: "Http Error response code 401 with response state text: Unauthorized while calling url: https://api.hireright.com:11443/is_gateway/sf ; Click text to download payload for further details"
- Click text to download payload for further details
- The payload shows:
{"__metadata": {"uri":"JobApplicationBackgroundCheckRequest","type":"SFOData.JobApplicationBackgroundCheckRequest"},"requestId":"1234","applicationId":"1234","vendorCode":"HIRERIGHT","responseCode":"ERROR","responseDetail":"Company/user not found"}
Cause
The 401 Unauthorized error was caused due to "Company/user not found".
Resolution
The 401 Unauthorized is an authentication error from the vendor end. Please reach out to the vendor for further assistance regarding the error response "Company/user not found".
Keywords
RCM, HIRERIGHT, Background check failed, 401 error, Unauthorized, Company/user not found, Network Error, initiate background check , KBA , LOD-SF-RCM-BCI , Background Check , Problem