SAP Knowledge Base Article - Public

3501089 - Message Replication From SAP External Systems to SAP Sales & Service Cloud v2 Fails in SAP Cloud Integration(CI)

Symptom

You are replicating the standard supported object data from SAP S4HANA / SAP ERP / other SAP External Systems to Sales & Service Cloud v2 and the messages fail in CPI with error message "org.apache.camel.component.ahc.AhcOperationFailedException: HTTP operation failed invoking https://myXXXXXXXX.YYY.test.crm.cloud.sap/sap/c4c/api/v1/inbound-data-connector-service/messages/sap.crm.md.integrationmetadataservice.entity with statusCode: 400."

Environment

SAP Sales & Service Cloud Integration with SAP S4HANA

Reproducing the Issue

  1. From S4 - You have implemented the prepackaged integration and start sending the data to Sales & Service Cloudv2 via DRFOUT or using SAP delivered ABAP Reports
  2. The messages fail in S4 monitor with 500 error, reference of MPL ID exists in detailed error log
  3. Go to CPI and search for MPL ID
  4. You can find the message fails with status 400

Cause

There could be multiple causes for this issue. The first thing you need to do is to enable the payload trace and resend the message from S4/any source system

  1. Missing SenderSystemID in the message
  2. Missing ReceiverSystemID in the message
  3. Incorrect Sender System is sent - which means the Sender System ID that is sent in the payload should match with the communication system id created for S4 integration in the V2 system
  4. Incorrect ReceiverSystemID is sent - It should match the default communication system id of your v2 system.

 
 

Resolution

Ensure proper system details are sent and the messages should be processed in CPI without fail. Read below points carefully

Communication / Business System Configuration in S/4HANA & SSCv2

  • The  SAP S/4HANA  communication system name in SAP Sales Cloud and SAP Service Cloud Version 2 must be  the same as the business system name in the System Landscape Directory of SAP S/4HANA. To check the business system name, use transaction SLDCHECK.
  • The business system name of SAP S/4HANA follows the pattern <SIDCLNTXXX>, where SID is the system ID and XXX is the Client number of the SAP backend System. 
  • In order to check the Local System ID when System Landscape Directory (SLDCHECK) is not available in the sys-tem, user has to implement the BADI “Determination of Local System Name” (MDG_IDM_GET_LCL_SYSTEM), the BADI can be found in SPRO transaction.
  • Path: > SAP Customizing Implementation Guide > Cross-Application Components > Processes and Tools for Enterprise Applications > Master Data Governance > Central Governance->General Settings > Key Mapping > Define Technical Settings > BAdI: Determination of Local System Name .
  • In S/4HANA when you create the Business System ID for Sales / Service Cloud V2 system - The ID should be in the format "sap_cloud_crm_my123456" which can be found in the Settings >> Communication Systems >> Find the system ID with description "Default communication System"
  • Check the reference KBA to create the logical system for IDoc based communications from SAP S/4HANA to Sales & Service Cloud v2

This configuration is very important to generate the SenderSystemID and ReceiverSystemID , for the messages to be processed in SAP Cloud Integration. 

Keywords

"org.apache.camel.component.ahc.AhcOperationFailedException" ; "HTTP operation failed invoking" ; "crm.cloud.sap/sap/c4c/api/v1/inbound-data-connector-service "; "sap.crm.md.integrationmetadataservice.entity "; "crm.cloud.sap/sap/c4c/api/v1/inbound-data-connector-service/messages/sap.crm.md.integrationmetadataservice.entity" , KBA , CEC-CRM-INT , Integration for SAP Sales/Service Cloud , CEC-CRM-UTIL , Utilities for SAP Sales/Service Cloud , CEC-CRM-DC , Data Connector for SAP Sales/Service Cloud , Problem

Product

SAP Sales Cloud and SAP Service Cloud Version 2 1.0