Symptom
Users we are facing randomly issues with work address country , for some records it is working without work address country for others it doesn’t. For the ones which doesn´t, it refers to the New Employee record/creation whereas for the ones which work, it refers to the employee delta changes.
It looks like there is a new validation in place which might be affecting the creation of new employees, but for the already created/replicated employee, the same replication works fine.
Environment
SAP Cloud for Sales Version 2
Employee Central
Reproducing the Issue
- Go to Settings
- Message Monitoring
- filter by entity: sap.crm.md.integrationmetadataservice.entity.employeeECReplicationMessageIn
Error details:
Enter a country/region.\",\"code\":\"sap.crm.md.service.addressService.addressMessage.countryIsMandatory\",\"target\":\"{workplaceAddress.country}\"
You might observe that even with similar payloads received (before June 2024 and after June 2024), the past one is Success and the new one raises the aforementioned error.
Cause
Postal address without country should not be considered, this validation was missing in the system logic and as of recent system deployments, the change implies that Country Region information is mandatory.
Resolution
Ensure you maintain the proper information of Country & Region for the employee in EC. As well as the information be also present underneath workplaceAddress node in the Incoming payload on SAP Cloud for Sales Version 2.
Keywords
workplaceAddress;country/region;employeeECReplicationMessageIn , KBA , CEC-CRM-INT , Integration for SAP Sales/Service Cloud , Known Error