Symptom
An issues occurs only for one or several specific users. The cause seems to be in the BW/S4 backend system.
Environment
SAC BW Live
Reproducing the Issue
It is not possible trace, analyze and debug an issue, which cannot be reproduced with the user provided to SAP Support.
Cause
The BW report contains user dependent elements, like authorization variables and custom code.
- A user, who can reproduce the issue usually doesn´t have permissions to analyze and debug the process in BW.
- A user who can analyze and debug the process in BW usually has more permissions, so the issue might not occur at all.
- Running a RSTT trace, which was recorded for an affected user, with a different user ID might get different results as well, because custom code might react on the particular current user ID.
Resolution
Copy an affected user to a test user. This should also copy the assigned roles and profiles.
1) Check, whether the issue is reproducible with the copied user. If it is reproducible ...
a) In the BW/S4 system, add permissions for the transactions RSBITT, RSTT and debugging (authorization object S_DEVELOP) to the copied user. These particular permissions are not expected to interfere with the capability to reproduce the issue. Please avoid to assign these permissions as part of a bigger bunch of permissions, like via an administrators role and SAP_ALL !
b) Provide the credentials of that user in the logon data depot to SAP Support.
2) If the issue is not reproducible with the copied user, it is an important hint. E.g. there might be user ID dependent coding involved in causing the issue. In such case, we cannot directly reproduce the issue. The only remaining option is to provide below points.
a) In BW/S4 add permissions for the transactions RSBITT, RSTT and debugging (authorization object S_DEVELOP) to the affected user.
b) Simplify the story as much as possible ! You may copy the story for this test and delete all elements, which are not directly required to reproduce the issue.
c) If the trace should be switched ON for the affected user by an administrator ensure, that note ##3318401 is in the system. Else nothing will be recorded.
d) Switch on the RSTT Trace for the affected user. Note ##2349246 - Transaction RSTT [VIDEO] shows how.
e) Reproduce the issue.
f) Provide the trace number to SAP Support.
The processor of the case might decide on further steps.
See Also
##2349246
##1895164
##3318401
Keywords
user-specific, user-dependent, RSTT , KBA , LOD-ANA-LDC-BW , SAC Live Data Connection BW , BW-BEX-OT-OLAP-AUT , Authorizations , BW-BEX-OT-BICS-INA , BW INA provider , How To