Symptom
Extension fields values are not added to the Invoice requests when you create the customer invoice requests via File Input run, even though you have added the extension field to the File Input Upload Excel and to the service ManageCustomerInvoiceRequestIn.
Environment
SAP Business Bydesign
Reproducing the Issue
- Go to the Application and User Management work center.
- Access the File Input work center view.
- Under Active Runs, select the respective run from the Service Interface CustomerInvoiceProcessingRequestInvoicingIn.
- Navigate to the Execution Details tab.
- In the generated customer invoice request, you can see the Extension field Values are blank
Cause
The File Input for Customer Invoices does not use the standard webservice Managecustomerinvoicerequestin.
Resolution
In order to add the extension field to the webservice used in the File Input for Customer Invoices, you need to extend the extension field to be used from:
- <BusinessObject> -> CustomerInvoiceRequest.
For example, you need to enable the extension scenario: Sales Order - General Information to Invoice Requests - General Information. If you enable this extension scenario, the extension fields will be automatically added to the correct webservice used in the File Input.
Keywords
File Input; Extension fields; do; not; populate; visible; customer; invoice; Maintaincustomerinvoicerequestin; Managecustomerinvoicerequestin; , KBA , AP-CI-CI , Customer Invoice , Problem