SAP Knowledge Base Article - Public

3501750 - Not all results are shown when searching for Products on the Opportunity creation screen

Symptom

On Opportunity quick create screen, when adding a Product then clicking on the help button for the Product just added, it doesn't show all results.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Sales > Opportunities;
  2. Click on new;
  3. On Products section click on add;
  4. Select any Product;
  5. Now click on the help button for the Product just added;
  6. See there are X results (X is the number for results);
  7. Click on advanced search and see it is filtered by the Category ID of the Product;
  8. If you delete it and search again it will now show all results.

Cause

This is not an issue as it is expected to have the search filtered by the product's category ID inside its own query.

Resolution

This is the expected system behavior.

If the feature/functionality is required urgently, please refer to KBA 3475641 - Functionality Currently not Available.

Keywords

KBA , LOD-CRM-OPP , Opportunity Management , Problem

Product

SAP Cloud for Customer core applications all versions