SAP Knowledge Base Article - Public

3502078 - Employee Address Replicated from SAP S4HANA Is Not Visible On Employee UI in SAP Sales & Service Cloud v2

Symptom

You are replicating the employee information from SAP S4HANA / SAP ERP / SAP Employee Central and the address is available in the incoming messages to V2 system but is not visible on UI

Environment

SAP Sales & Service Cloud Integration with SAP S4HANA

Reproducing the Issue

  1. Replicate a new employee from S4HANA or ERP or EC
  2. Check the incoming message in Sales & Service Cloudv2
  3. Open the payload and see the address available
  4. Go to the employee UI and find the address is missing

Cause

Only Workplace address of an employee is considered during employee creation or updation process. Employees personal information or personal address is not considered as it is not useful in Sales & Service Cloud v2 business process. Employee information is always used in the Account / Sales documents where the address gets captured from Account which is considered as Employees work address.

In the incoming message if you find  "isWorkplaceAddress": "false" - then the address is not considered for update. 

Resolution

This is the expected system behavior. 

If you wish to have the employees personal address as well saved, then you can use the value mapping available for the field isWorkplaceAddress in the standard iflows. Please note even if you send the employees personal address, it may not be possible to use this address in the business transactions as the address is always considered from account.

Keywords

"Employee Address not visible" ; "Employee address not replicated" ; "workplaceaddress" , KBA , CEC-CRM-INT , Integration for SAP Sales/Service Cloud , Problem

Product

SAP Sales Cloud and SAP Service Cloud Version 2 1.0