Symptom
User encounters Exception: EXC_BAD_ACCESS error while saving E-mail in Mac(Server-side integration).
Environment
SAP Cloud for Customer.
Reproducing the Issue
1.Navigate to Outlook.
2.Click on any Email and try to save it to C4C.
3.User encounters Error: Exception: EXC_BAD_ACCESS error.
Cause
The error EXC_BAD_ACCESS comes from the user Outlook. The save process was successful, however, on an attempt to write technical information to the item in the user Mailbox, Outlook showed the mentioned error.
This type of error usually indicates that there is a problem with the Outlook database.
Resolution
1. Update Outlook for Mac: Ensure that Outlook is updated to the latest version available.
2. Rebuild Outlook Database:
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Quit Outlook
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Go to the folder (check the article to determine which version the user has - https://answers.microsoft.com/en-us/outlook_com/forum/all/wheres-the-outlook-database-located-on-the-hard/8b3d838b-d863-4071-9765-88a1c4134f08)~/Library/Group Containers/UBF8T346G9.Office/Outlook/Outlook 15 Profiles/Main Profile/Data (You can press “Cmd+Shift+G” in Finder to navigate to this folder.)
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Move the Outlook.sqllite file to a different location, such as the Desktop, to keep it as a backup.
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Launch Outlook again.
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Outlook will prompt you to repair your database. Click on "Repair". This will force Outlook to restore its database and rebuild the index. Please note that this process may take around 2-3 hours on a speedy MacBook Pro.
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The folder ~/Library/Group Containers/UBF8T346G9.Office/Outlook/Outlook 15 Profiles/ will contain backups of your previous database. If you want to free up disk space, you can choose to archive or delete this folder.
3. Reinstall Microsoft Outlook: If the issue persists, consider reinstalling Microsoft Outlook to ensure a clean installation.
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First, uninstall Microsoft Outlook completely from your Mac.
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Restart your macOS and reinstall the Office application.
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Make sure to empty the trash after uninstalling to complete the process.
4. Create a new Outlook Profile (Refer to Manage profiles or identities in Outlook for Mac - Microsoft Support please do not delete the old profile to prevent the loss of your data) and check if the issue can be replicated
5.Open a new ticket with Outlook for Mac support.
Keywords
Macbook,Server-side Integration , KBA , LOD-CRM-GW-OUT , Outlook , Problem