Symptom
The value for the attribute "Check Customer Reference" is set to "blank - no check" for sales document type "OR" in the configuration activity "Configure Sales Document Types (ID: 102495)". When creating sales order manually with a customer reference for which another sales order exists for this customer, the system does not throw message that another sales order exists. However, when creating sales orders with API "Sales Order/Customer Return - Create, Update, Cancel (B2B)", it is still looking for existing sales orders for the customer reference. If an existing sales order is found, that sales order will be updated. Also, the API process fails with message: "Purchase order &1 of customer &2 is referenced by multiple sales orders".
Environment
SAP S/4HANA Cloud Public Edition
Cause
Different with manually creating sales orders or using "Synchronous" APIs, for the "Asynchronous" API such as "Sales Order/Customer Return - Create, Update, Cancel (B2B)", if it is allowed to use the same purchase order number, it will lead to confusion to the system when the request for the previous sales order is sent and the response hasn't come back yet, while the request for a new sales order have already been sent.
Resolution
As explained in the "Cause" part, this is the standard behaviour of "Asynchronous" APIs.
Keywords
Check customer reference, Blank, No check, Sales document type, OR, Configuration activity, Configure sales document types, 102495, Sales order, Manually, Customer reference, API, Sales Order/Customer Return - Create, Update, Cancel (B2B), Existing sales order, Purchase order, Multiple sales orders , KBA , SD-SLS-API-2CL , API (Public Cloud) , Problem