Symptom
You created a custom party role based on the account party as a source, and you notice that upon creating a case and adding the account, the custom party is not determined as expected.
Environment
SAP Service Cloud Version 2.
Reproducing the Issue
- Logon to your V2 environment.
- Navigate to Cases work list.
- Click + to create a new case.
- Fill in all mandatory details.
- Add any account.
- Click Save and Open.
- Navigate to the Involved Parties section under the General tab.
- See the custom party based on the account has not been determined.
Cause
The custom party has a Relationship Type maintained under the Party Processing settings, however, this party was not added under the Account Relationships section under the General tab.
Resolution
In order to ensure the custom party is determined as expected in the case, you need to make sure the party is added in the account relationships, following the steps below:
- Navigate to Account work list.
- Open any account.
- Under the General tab, scroll down until the Relationships tab.
- Add the respective business partner and set it with the same relationship type as maintained in the custom party settings.
- Save the changes.
Once this is done, the custom party will be determined as expected during the case creation when the account is maintained.
Keywords
Custom, Party, Custom Party, Party Processing, Account, Relationship, Relationship Type, Type, Case, Creation, Determination, Case Creation, Create, Involved Party, V2, SAP Service Cloud Version 2, Version 2, , KBA , CEC-CRM-CAS , Case Management for SAP Sales/Service Cloud , CEC-CRM-PAP , Party Processing for SAP Sales/Service Cloud , CEC-CRM-ACC , Account for SAP Sales/Service Cloud , How To