SAP Knowledge Base Article - Public

3503718 - Error message "No customer master record exists for sold-to party xxxxxxxxxx" displayed when creating a Sales Order

Symptom

Although customer master data is correctly maintained, creating a sales order it's not possible due to error message "No customer master record exists for sold-to party xxxxxxxxxx".

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. Go to app Create Sales Orders - VA01;
  2. Create a new order for a customer;
  3. It's not possible due to error message: "No customer master record exists for sold-to party xxxxxxxxxx".

Cause

Customer is not assigned to a Sales Area.

Resolution

  1.  Go to app 'Manage Customer Master Data'.
  2. Search for the Customer and select it.
  3. Open the Customer in Edit mode.
  4. Go to 'Sales Areas' tab and assign the Customer to the relevant values for the sales area (Sales Organization, Distribution Channel and Division).
  5. The partner functions for Sold-to Party, Ship-to Party, Bill-to Party and Payer will be populated.
  6. The user can change these manually or leave as the default values. 
  7. Click Save.

See Also

Keywords

sold-to party, ship-to party, bill-to party, payer, partner functions, customer master data, master data, business partner, sales area, BP, KU, SP, BP, PY, SH , KBA , SD-SLS-SO-2CL , Sales Orders (Public Cloud) , Problem

Product

SAP S/4HANA Cloud Public Edition all versions