Symptom
Although customer master data is correctly maintained, creating a sales order it's not possible due to error message "No customer master record exists for sold-to party xxxxxxxxxx".
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Go to app Create Sales Orders - VA01;
- Create a new order for a customer;
- It's not possible due to error message: "No customer master record exists for sold-to party xxxxxxxxxx".
Cause
Customer is not assigned to a Sales Area.
Resolution
- Go to app 'Manage Customer Master Data'.
- Search for the Customer and select it.
- Open the Customer in Edit mode.
- Go to 'Sales Areas' tab and assign the Customer to the relevant values for the sales area (Sales Organization, Distribution Channel and Division).
- The partner functions for Sold-to Party, Ship-to Party, Bill-to Party and Payer will be populated.
- The user can change these manually or leave as the default values.
- Click Save.
See Also
Keywords
sold-to party, ship-to party, bill-to party, payer, partner functions, customer master data, master data, business partner, sales area, BP, KU, SP, BP, PY, SH , KBA , SD-SLS-SO-2CL , Sales Orders (Public Cloud) , Problem
Product
SAP S/4HANA Cloud Public Edition all versions