SAP Knowledge Base Article - Public

3503758 - "CAMEL_CONTEXT_NOT_STARTED" error for Replicate Equipment from SAP S4HANA iflow

Symptom

You have followed the configuration steps to implement the replication of equipment from S4Hana to Sales Cloud Version 2 but when you deploy the respective iflow, you get the error:

[CONTENT][CONTENT_DEPLOY][InstanceError] : {"message":"CAMEL_CONTEXT_NOT_STARTED"}

Environment

SAP Cloud for Sales Version 2

S/4Hana 

SAP Cloud Integration

Reproducing the Issue

  1. Go to Cloud Integration Monitor page
  2. For the Manage Integration Content; select the Integration Content named Replicate Equipment from SAP S4HANA 
  3. Check if the error refers to CAMEL_CONTEXT_NOT_STARTED and connection time out

Cause

You might have included the AMPQ Protocol along with the URI

(e.g. enterprise-messaging-messaging-gateway.cfapps.xxx.hana.ondemand.com/protocols/amqp10ws:443/protocols/amqp10ws/default/)  

Resolution

  1. Go to Cloud Integration
  2. Go to Design 
  3. Open the package: Integrate master data between SAP Sales and SAP Service Cloud Version 2 and SAP S/4HANA or SAP S/4HANA Cloud 
  4. Open the configuration mode of Replicate Equipment from SAP S4HANA 
  5. Select the AMQP adapter
  6. certify you maintain the path field

Ensure the Path: /protocols/amqp10ws is not also added to message host.

Otherwise the protocol path would be automatically appended (/protocols/amqp10ws) from the adapter configuration. 

See Also

Please Note: In case the AMQP adapter is a receiver adapter, you can come across a different error but due to the same cause:

org.springframework.jms.UncategorizedJmsException: Uncategorized exception occurred during JMS processing; nested exception is javax.jms.JMSException: connection timed out after 60000 ms: enterprise-messaging-hub-backend.cfapps.xx10.hana.ondemand.com/, cause: io.netty.channel.ConnectTimeoutException: connection timed out after 60000 ms: enterprise-messaging-hub-backend.cfapps.xx10.hana.ondemand.com/

where xx10 refers to your CPI Tenant ID. 

Keywords

CAMEL_CONTEXT_NOT_STARTED;amqp10ws;ConnectTimeoutException , KBA , CEC-CRM-INT , Integration for SAP Sales/Service Cloud , Problem

Product

SAP Sales Cloud and SAP Service Cloud Version 2 1.0

Attachments

Error.png
Path cfg.png