Symptom
You have the requirement to configure Identity Provisioning (IPS) from your Identity Services tenant for automatic user creation.
However, it seems it is not yet available in CNS (API hub). You would like to know about the provisioning of this functionality and steps involved.
Environment
SAP Sales Cloud for Customer Version 2
SAP Service Cloud for Customer Version 2
Identity Provisioning
Reproducing the Issue
Potential Use Case: Connect the Sales Cloud and Service Cloud Version 2 using the SAP IPS framework.
e.g. You are trying to obtain data on Business Users and Business Roles using the IPS system, however you are not able to find the respective Communication Scenario in the available list in Sales Cloud Version 2.
Cause
Currently not yet supported.
Resolution
The implementation of full scenario depends on two work-streams and phases:
- Phase 1 - IAM Development at CNS side: development and release of SCIM APIs
- Phase 2 - IPS Development at IPS side: development and release of respective Connector for the APIs
Current Status:
The Phase 1 has been completed and Phase 2 remains under development.
See Also
What APIs can I use to obtain business users, business roles, and security policies in SAP Sales Cloud?
You can refer to the following IAM (Identity and access management) APIs:
- Business roles: /sap/c4c/api/v1/iam-service/roles
- Business users: /sap/c4c/api/v1/iam-service/users
- Security policies: /sap/c4c/api/v1/iam-service/securityPolicies
Keywords
SCIM;IPS; CNS; IAM , KBA , CEC-CRM-INT , Integration for SAP Sales/Service Cloud , Product Enhancement