Symptom
When upserting background information via API, entering the same value for both Start Date and End Date parameters results to an error:
Error on entity outsideWorkExperience - Fields: End date must be after Start date.
On the other hand, when same change is done via UI, either on External or Internal Candidate Profile (mobile apply / non-mobile apply), and Employee Profile, system accepts same date value for the Start Date and End Date background fields.
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
Upsert Outside Work Experience background data of a candidate via API:
Example (demo instance):
https://api68sales.successfactors.com/odata/v2/upsert/
Cause
Engineering Team confirmed that this inconsistency in behavior needs to be corrected.
Resolution
Engineering Team will proceed on system enhancement to change the system behavior to allow same date values on Start Date and End Date background fields when upserting via OData API.
This system behavior change is included on the road map and will be deployed as part of 2H 2024 Release:
- Preview: October 14, 2024
- Production: November 15-17, 2024
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See Also
- Product Release & Road Map Information
- 2171560 - How to mark a KBA or SAP Note as a favorite and get notified when it is updated - SAP for Me.
Keywords
API, Upsert, Start Date, End Date, Background, Outside Work Experience, Error, RCM-142494 , KBA , LOD-SF-RCM-API , Webservices & APIs , LOD-SF-RCM-CAN , General Candidate Issues (not Offers, not Profiles) , Problem